aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch')
-rw-r--r--recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch b/recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch
new file mode 100644
index 0000000000..9f8f025d82
--- /dev/null
+++ b/recipes/gcc/gcc-4.3.1/debian/mudflap-nocheck.dpatch
@@ -0,0 +1,36 @@
+#! /bin/sh -e
+
+# DP: Disable running the libmudflap testsuite. Getting killed on alpha.
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- libmudflap/testsuite/Makefile.in~ 2005-09-23 18:33:47.000000000 +0200
++++ libmudflap/testsuite/Makefile.in 2006-03-25 20:31:45.044903808 +0100
+@@ -218,6 +218,8 @@
+
+
+ check-DEJAGNU: site.exp
++ @echo target $@ disabled for Debian build.
++check-DEJAGNU-disabled: site.exp
+ srcdir=`$(am__cd) $(srcdir) && pwd`; export srcdir; \
+ EXPECT=$(EXPECT); export EXPECT; \
+ runtest=$(RUNTEST); \