aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch')
-rw-r--r--recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch b/recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch
new file mode 100644
index 0000000000..19d67d88ba
--- /dev/null
+++ b/recipes/gcc/gcc-4.3.2/debian/libjava-xulrunner1.9.dpatch
@@ -0,0 +1,41 @@
+#! /bin/sh -e
+
+# DP: Add configure check for xulrunner-1.9.
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ cd ${dir}libjava/classpath && aclocal -I m4 -I ../.. -I ../../config && autoconf
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ rm -f ${dir}libjava/configure
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- libjava/classpath/configure.ac~ 2008-02-22 08:37:10.356094701 +0100
++++ libjava/classpath/configure.ac 2008-02-22 08:38:49.397588719 +0100
+@@ -702,7 +702,10 @@
+
+ dnl Check for plugin support headers and libraries.
+ if test "x${COMPILE_PLUGIN}" = xyes; then
+- PKG_CHECK_MODULES(MOZILLA, mozilla-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin libxul-unstable, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ if test "x${MOZILLA_FOUND}" = xno; then
++ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ fi
+ if test "x${MOZILLA_FOUND}" = xno; then
+ PKG_CHECK_MODULES(MOZILLA, firefox-plugin firefox-xpcom, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
+ fi