aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdal/gdal_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gdal/gdal_1.3.2.bb')
-rw-r--r--recipes/gdal/gdal_1.3.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gdal/gdal_1.3.2.bb b/recipes/gdal/gdal_1.3.2.bb
new file mode 100644
index 0000000000..60f86b165a
--- /dev/null
+++ b/recipes/gdal/gdal_1.3.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=internal \
+ --with-png=internal \
+ --with-jpeg=internal \
+ --with-libtiff=internal \
+ "
+
+do_configure_append() {
+ sed -i s:/usr/lib:${D}${libdir}: GDALmake.opt
+ sed -i s:/usr/bin:${D}${bindir}: GDALmake.opt
+ sed -i s:/usr/share:${D}${datadir}: GDALmake.opt
+ sed -i s:/usr/include:${D}${includedir}: GDALmake.opt
+}
+
+do_compile() {
+ oe_runmake default
+}
+
+
+do_package_prepend() {
+ # the brokenness....
+ os.system('cp -pPR ${D}${D}* ${D}../')
+}
+
+do_stage() {
+ autotools_stage_all
+}
+