aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geode-drivers/geode-aeslx_2.6.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/geode-drivers/geode-aeslx_2.6.11.bb')
-rw-r--r--recipes/geode-drivers/geode-aeslx_2.6.11.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/geode-drivers/geode-aeslx_2.6.11.bb b/recipes/geode-drivers/geode-aeslx_2.6.11.bb
new file mode 100644
index 0000000000..fdcbdbf20b
--- /dev/null
+++ b/recipes/geode-drivers/geode-aeslx_2.6.11.bb
@@ -0,0 +1,19 @@
+# AES OE build file for the AMD Geode LX
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux AES Driver for the AMD Geode LX processor"
+HOMEPAGE = "http://www.amd.com/embedded"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "02.01.0100"
+AMD_DRIVER_LABEL = "AES_Linux_LX_${AMD_DRIVER_VERSION}"
+
+require geode-modules.inc
+
+FILES_${PN} += " /etc"
+
+do_install_append(){
+ install -d ${D}/etc/modules.d
+ echo options geodeaes rsvd_mem=0x200000 > ${D}/etc/modules.d/aes
+}