aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gimp/gegl_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gimp/gegl_svn.bb')
-rw-r--r--recipes/gimp/gegl_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gimp/gegl_svn.bb b/recipes/gimp/gegl_svn.bb
new file mode 100644
index 0000000000..7f49e785ac
--- /dev/null
+++ b/recipes/gimp/gegl_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GEGL (Generic Graphics Library) is a graph based image processing framework."
+LICENSE = "LGPL"
+DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl"
+
+SRCREV = "2543"
+PV = "0.0.19+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+inherit gnome
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN};module=trunk \
+ file://gegl-resilience.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-docs "
+
+FILES_${PN} += "${libdir}/gegl-0.0"
+FILES_${PN}-dbg += "${libdir}/gegl-0.0/.debug"
+
+
+do_stage() {
+ autotools_stage_all
+}
+