aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glibc/glibc_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/glibc/glibc_2.6.1.bb')
-rw-r--r--recipes/glibc/glibc_2.6.1.bb50
1 files changed, 25 insertions, 25 deletions
diff --git a/recipes/glibc/glibc_2.6.1.bb b/recipes/glibc/glibc_2.6.1.bb
index 86e6dca9b6..104ce88170 100644
--- a/recipes/glibc/glibc_2.6.1.bb
+++ b/recipes/glibc/glibc_2.6.1.bb
@@ -37,46 +37,46 @@ SRC_URI = "\
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2;name=archive \
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-${PV}.tar.bz2;name=ports \
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2;name=libidn \
- file://arm-memcpy.patch;patch=1 \
- file://arm-longlong.patch;patch=1 \
- file://fhs-linux-paths.patch;patch=1 \
- file://dl-cache-libcmp.patch;patch=1 \
- file://nptl-crosscompile.patch;patch=1 \
- file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
- file://glibc-check_pf.patch;patch=1;pnum=0 \
- file://zecke-sane-readelf.patch;patch=1 \
- file://ldd-unbash.patch;patch=1 \
+ file://arm-memcpy.patch;apply=yes \
+ file://arm-longlong.patch;apply=yes \
+ file://fhs-linux-paths.patch;apply=yes \
+ file://dl-cache-libcmp.patch;apply=yes \
+ file://nptl-crosscompile.patch;apply=yes \
+ file://glibc-2.5-local-dynamic-resolvconf.patch;apply=yes;striplevel=0 \
+ file://glibc-check_pf.patch;apply=yes;striplevel=0 \
+ file://zecke-sane-readelf.patch;apply=yes \
+ file://ldd-unbash.patch;apply=yes \
file://generic-bits_select.h \
file://generic-bits_types.h \
file://generic-bits_typesizes.h \
file://generic-bits_time.h \
file://etc/ld.so.conf \
file://generate-supported.mk \
- file://glibc-2.6.1-RTLD_SINGLE_THREAD_P-1.patch;patch=1 \
- file://glibc-2.6.1-use-short-for-fnstsw.patch;patch=1 \
- file://glibc-use-isystem-include-fixed.patch;patch=1 \
- file://glibc-arm-no-asm-page.patch;patch=1 \
- file://armv4t-interworking.patch;patch=1 \
- file://march-i686.patch;patch=1;pnum=0 \
+ file://glibc-2.6.1-RTLD_SINGLE_THREAD_P-1.patch;apply=yes \
+ file://glibc-2.6.1-use-short-for-fnstsw.patch;apply=yes \
+ file://glibc-use-isystem-include-fixed.patch;apply=yes \
+ file://glibc-arm-no-asm-page.patch;apply=yes \
+ file://armv4t-interworking.patch;apply=yes \
+ file://march-i686.patch;apply=yes;striplevel=0 \
"
SRC_URI_append_ep9312 = "\
- file://glibc-crunch-endian-littleword-littlebyte.patch;patch=1 \
- file://glibc-crunch-eabi-setjmp_longjmp.patch;patch=1 \
- file://glibc-crunch-eabi-unwind.patch;patch=1 \
- file://glibc-crunch-eabi.patch;patch=1 \
- file://glibc-crunch-eabi-force.patch;patch=1 \
- file://glibc-crunch-eabi-fraiseexcpt.patch;patch=1 \
+ file://glibc-crunch-endian-littleword-littlebyte.patch;apply=yes \
+ file://glibc-crunch-eabi-setjmp_longjmp.patch;apply=yes \
+ file://glibc-crunch-eabi-unwind.patch;apply=yes \
+ file://glibc-crunch-eabi.patch;apply=yes \
+ file://glibc-crunch-eabi-force.patch;apply=yes \
+ file://glibc-crunch-eabi-fraiseexcpt.patch;apply=yes \
"
# Build fails on sh3 and sh4 without additional patches
-SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
-SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
+SRC_URI_append_sh3 = " file://no-z-defs.patch;apply=yes"
+SRC_URI_append_sh4 = " file://no-z-defs.patch;apply=yes"
# PowerPC Patches to add support for soft-float
SRC_URI_append_powerpc = "\
- file://powerpc-sqrt-hack.diff;patch=1 \
- file://glibc-2.6.1-powerpc-nofpu.patch;patch=1 \
+ file://powerpc-sqrt-hack.diff;apply=yes \
+ file://glibc-2.6.1-powerpc-nofpu.patch;apply=yes \
"
S = "${WORKDIR}/glibc-${PV}"