aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glibc/glibc_2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/glibc/glibc_2.9.bb')
-rw-r--r--recipes/glibc/glibc_2.9.bb56
1 files changed, 28 insertions, 28 deletions
diff --git a/recipes/glibc/glibc_2.9.bb b/recipes/glibc/glibc_2.9.bb
index ab5ddcb14b..e7ab63d6d6 100644
--- a/recipes/glibc/glibc_2.9.bb
+++ b/recipes/glibc/glibc_2.9.bb
@@ -36,52 +36,52 @@ python __anonymous () {
RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
-# file://noinfo.patch;apply=yes
-# file://ldconfig.patch;apply=yes;striplevel=0
-# file://arm-machine-gmon.patch;apply=yes;striplevel=0 \
+# file://noinfo.patch
+# file://ldconfig.patch;striplevel=0
+# file://arm-machine-gmon.patch;striplevel=0 \
# \
-# file://arm-ioperm.patch;apply=yes;striplevel=0 \
-# file://ldd.patch;apply=yes;striplevel=0 \
+# file://arm-ioperm.patch;striplevel=0 \
+# file://ldd.patch;striplevel=0 \
SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2;name=archive \
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-${PV}.tar.bz2;name=ports \
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-${PV}.tar.bz2;name=libidn \
- file://nscd-init.patch;apply=yes;striplevel=0 \
- file://arm-memcpy.patch;apply=yes \
- file://arm-longlong.patch;apply=yes \
- file://fhs-linux-paths.patch;apply=yes \
- file://dl-cache-libcmp.patch;apply=yes \
- file://ldsocache-varrun.patch;apply=yes \
- file://nptl-crosscompile.patch;apply=yes \
- file://glibc-check_pf.patch;apply=yes;striplevel=0 \
- file://ldd-unbash.patch;apply=yes \
- file://glibc-arm-IO-acquire-lock-fix.diff;apply=yes \
+ file://nscd-init.patch;striplevel=0 \
+ file://arm-memcpy.patch \
+ file://arm-longlong.patch \
+ file://fhs-linux-paths.patch \
+ file://dl-cache-libcmp.patch \
+ file://ldsocache-varrun.patch \
+ file://nptl-crosscompile.patch \
+ file://glibc-check_pf.patch;striplevel=0 \
+ file://ldd-unbash.patch \
+ file://glibc-arm-IO-acquire-lock-fix.diff \
file://generic-bits_select.h \
file://generic-bits_types.h \
file://generic-bits_typesizes.h \
file://generic-bits_time.h \
file://etc/ld.so.conf \
file://generate-supported.mk \
- file://march-i686.patch;apply=yes;striplevel=0 \
- file://tls_i486.patch;apply=yes \
- file://glibc-2.9-use-_begin.patch;apply=yes \
- file://arm-lowlevellock-include-tls.patch;apply=yes \
- file://glibc-2.9-enable-binutils-2.2.patch;apply=yes \
+ file://march-i686.patch;striplevel=0 \
+ file://tls_i486.patch \
+ file://glibc-2.9-use-_begin.patch \
+ file://arm-lowlevellock-include-tls.patch \
+ file://glibc-2.9-enable-binutils-2.2.patch \
"
# patches to fix libmemusage.so
-SRC_URI_append = " file://0001-malloc-memusage.c-update_data-Fix-handling-of-wrappi.patch;apply=yes \
- file://0002-malloc-memusage.c-DEFAULT_BUFFER_SIZE-Change-to-3276.patch;apply=yes \
- file://0003-Fix-wrap-around-in-memusage.patch;apply=yes "
+SRC_URI_append = " file://0001-malloc-memusage.c-update_data-Fix-handling-of-wrappi.patch \
+ file://0002-malloc-memusage.c-DEFAULT_BUFFER_SIZE-Change-to-3276.patch \
+ file://0003-Fix-wrap-around-in-memusage.patch "
# Build fails on sh3 and sh4 without additional patches
-SRC_URI_append_sh3 = " file://no-z-defs.patch;apply=yes \
- file://glibc-2.9-sh-fix.patch;apply=yes"
-SRC_URI_append_sh4 = " file://no-z-defs.patch;apply=yes \
- file://glibc-2.9-sh-fix.patch;apply=yes"
+SRC_URI_append_sh3 = " file://no-z-defs.patch \
+ file://glibc-2.9-sh-fix.patch"
+SRC_URI_append_sh4 = " file://no-z-defs.patch \
+ file://glibc-2.9-sh-fix.patch"
#powerpc patches to add support for soft-float
-SRC_URI_append_powerpc= " file://powerpc-sqrt-hack.diff;apply=yes"
+SRC_URI_append_powerpc= " file://powerpc-sqrt-hack.diff"
S = "${WORKDIR}/glibc-${PV}"
B = "${WORKDIR}/build-${TARGET_SYS}"