aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnash/gnash_0.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnash/gnash_0.8.4.bb')
-rw-r--r--recipes/gnash/gnash_0.8.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gnash/gnash_0.8.4.bb b/recipes/gnash/gnash_0.8.4.bb
new file mode 100644
index 0000000000..0a9c780cc4
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.4.bb
@@ -0,0 +1,24 @@
+require gnash.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ "
+