aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-icon-theme_2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-icon-theme_2.24.0.bb')
-rw-r--r--recipes/gnome/gnome-icon-theme_2.24.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-icon-theme_2.24.0.bb b/recipes/gnome/gnome-icon-theme_2.24.0.bb
new file mode 100644
index 0000000000..755e39151e
--- /dev/null
+++ b/recipes/gnome/gnome-icon-theme_2.24.0.bb
@@ -0,0 +1,29 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "icon-naming-utils-native glib-2.0 intltool-native"
+RDEPENDS = "hicolor-icon-theme"
+RRECOMMENDS = "librsvg-gtk"
+
+PR = "r2"
+
+FILES_${PN} += "${datadir}/*"
+
+EXTRA_OECONF = "--disable-hicolor-check"
+
+inherit gnome
+
+pkg_postinst_${PN}() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+# Update the pixbuf loaders in case they haven't been registered yet
+gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+
+gtk-update-icon-cache -q /usr/share/icons/gnome
+}
+
+pkg_postrm_${PN}() {
+gtk-update-icon-cache -q /usr/share/icons/gnome
+}
+