aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-keyring_2.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-keyring_2.24.1.bb')
-rw-r--r--recipes/gnome/gnome-keyring_2.24.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.24.1.bb b/recipes/gnome/gnome-keyring_2.24.1.bb
new file mode 100644
index 0000000000..105ee16d11
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.24.1.bb
@@ -0,0 +1,25 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libtasn1 libgcrypt"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+
+do_stage() {
+ autotools_stage_all
+}