aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python_2.26.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-python_2.26.1.bb')
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
index 1027437b7a..54523f898f 100644
--- a/recipes/gnome/gnome-python_2.26.1.bb
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -3,13 +3,18 @@ LICENSE = "LGPL"
DEPENDS = "libgnomeui pyorbit python-pygtk"
RDEPENDS = "pyorbit"
+PR = "r1"
+
inherit gnome distutils-base pkgconfig
-do_configure() {
- sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
- autotools_do_configure
+
+do_configure_prepend() {
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
}
do_stage() {