aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-themes_2.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-themes_2.6.2.bb')
-rw-r--r--recipes/gnome/gnome-themes_2.6.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-themes_2.6.2.bb b/recipes/gnome/gnome-themes_2.6.2.bb
new file mode 100644
index 0000000000..2c18b59654
--- /dev/null
+++ b/recipes/gnome/gnome-themes_2.6.2.bb
@@ -0,0 +1,31 @@
+SECTION = "x11/base"
+LICENSE = "LGPL"
+DESCRIPTION = "GNOME themes"
+
+DEPENDS = "gtk-engines intltool-native"
+
+PACKAGES += " gtk-engine-crux gtk-engine-hc gtk-engine-lighthouseblue gtk-engine-mist gtk-engine-thinice"
+FILES_gtk-engine-crux = "${libdir}/gtk-2.0/*/engines/libcrux-engine.so"
+FILES_gtk-engine-hc = "${libdir}/gtk-2.0/*/engines/libhcengine.so"
+FILES_gtk-engine-lighthouseblue = "${libdir}/gtk-2.0/*/engines/liblighthouseblue.so"
+FILES_gtk-engine-mist = "${libdir}/gtk-2.0/*/engines/libmist.so"
+FILES_gtk-engine-thinice = "${libdir}/gtk-2.0/*/engines/libthinice.so"
+
+PACKAGES += " gnome-theme-crux gnome-theme-grand-canyon gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-lighthouseblue gnome-theme-mist gnome-theme-traditional"
+FILES_gnome-theme-crux = "${datadir}/themes/Crux"
+FILES_gnome-theme-grand-canyon = "${datadir}/themes/Grand-Canyon"
+FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast"
+FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse"
+FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint"
+FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse"
+FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint"
+FILES_gnome-theme-lighthouseblue = "${datadir}/themes/LighthouseBlue"
+FILES_gnome-theme-mist = "${datadir}/themes/Mist"
+FILES_gnome-theme-traditional = "${datadir}/themes/Traditional"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
+
+# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
+CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')}"
+
+inherit autotools