aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/goffice_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/goffice_0.6.3.bb')
-rw-r--r--recipes/gnome/goffice_0.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gnome/goffice_0.6.3.bb b/recipes/gnome/goffice_0.6.3.bb
new file mode 100644
index 0000000000..86f9f4e943
--- /dev/null
+++ b/recipes/gnome/goffice_0.6.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+PR ="r0"
+
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+inherit gnome pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+