aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/libsoup_2.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/libsoup_2.2.7.bb')
-rw-r--r--recipes/gnome/libsoup_2.2.7.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/gnome/libsoup_2.2.7.bb b/recipes/gnome/libsoup_2.2.7.bb
new file mode 100644
index 0000000000..c0f0ab22bf
--- /dev/null
+++ b/recipes/gnome/libsoup_2.2.7.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+DESCRIPTION = "An HTTP library implementation in C"
+SECTION = "x11/gnome/libs"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${PN}/2.2/${PN}-${PV}.tar.bz2"
+DEPENDS = "glib-2.0 gnutls libxml2"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${includedir} ${libdir}"
+FILES_${PN}-doc = "${datadir}"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/pkgconfig
+ install -m 0644 ${S}/*.pc ${STAGING_DATADIR}/pkgconfig/
+}