aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/metacity_2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/metacity_2.24.0.bb')
-rw-r--r--recipes/gnome/metacity_2.24.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gnome/metacity_2.24.0.bb b/recipes/gnome/metacity_2.24.0.bb
new file mode 100644
index 0000000000..c36958f54b
--- /dev/null
+++ b/recipes/gnome/metacity_2.24.0.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Metacity is the boring window manager for the adult in you."
+LICENSE = "GPL"
+DEPENDS = "libwnck startup-notification gtk+ gconf gdk-pixbuf-csource-native"
+
+PR = "r1"
+
+inherit gnome update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/metacity"
+ALTERNATIVE_PRIORITY = "30"
+
+EXTRA_OECONF += "--disable-verbose \
+ --disable-xinerama"
+
+FILES_${PN} += "${datadir}/themes ${datadir}/gnome*"
+
+do_stage () {
+ autotools_stage_all
+}