aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuchess
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnuchess')
-rw-r--r--recipes/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch23
-rw-r--r--recipes/gnuchess/files/fltk-chess.desktop7
-rw-r--r--recipes/gnuchess/fltk-chess_0.5.bb33
-rw-r--r--recipes/gnuchess/fltk-chess_0.51.bb29
-rw-r--r--recipes/gnuchess/gnuchess_5.021.bb13
-rw-r--r--recipes/gnuchess/gnuchess_5.05.bb10
6 files changed, 115 insertions, 0 deletions
diff --git a/recipes/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch b/recipes/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch
new file mode 100644
index 0000000000..8dba103dc3
--- /dev/null
+++ b/recipes/gnuchess/files/fix_cast_error_and_gnuchess_exec.patch
@@ -0,0 +1,23 @@
+diff -Naur fltk-chess.orig/fltk-chess.cxx fltk-chess/fltk-chess.cxx
+--- fltk-chess.orig/fltk-chess.cxx 2005-08-25 01:42:28.000000000 +0400
++++ fltk-chess/fltk-chess.cxx 2008-05-17 19:26:57.000000000 +0400
+@@ -705,8 +705,8 @@
+
+ void cb_P(Fl_Widget * ob, void *p)
+ {
+-
+- changeP = (char) p;
++ int temp_p = (int) p;
++ changeP = (char) temp_p;
+ }
+
+
+@@ -881,7 +881,7 @@
+ // close(fdFrom[0]);
+ // close(fdFrom[1]);
+
+- execl("./gnuchess", NULL);
++ execl("/bin/sh", "/bin/sh", "-c", "exec gnuchess", NULL);
+
+ } else {
+
diff --git a/recipes/gnuchess/files/fltk-chess.desktop b/recipes/gnuchess/files/fltk-chess.desktop
new file mode 100644
index 0000000000..6c422659d6
--- /dev/null
+++ b/recipes/gnuchess/files/fltk-chess.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=FLTK Chess
+Comment=FLTK frontend to GNUchess
+Exec=fltk-chess
+Type=Application
+Icon=fltk-chess
+Categories=Game;BoardGame;
diff --git a/recipes/gnuchess/fltk-chess_0.5.bb b/recipes/gnuchess/fltk-chess_0.5.bb
new file mode 100644
index 0000000000..fae7411329
--- /dev/null
+++ b/recipes/gnuchess/fltk-chess_0.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
+AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
+SECTION = "x11/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk"
+RDEPENDS = "gnuchess"
+
+
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/fltk-chess-${PV}.tgz \
+ file://fix_cast_error_and_gnuchess_exec.patch;patch=1 \
+ file://fltk-chess.desktop"
+S = "${WORKDIR}/fltk-chess/"
+
+
+do_compile() {
+ `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
+ fltk-chess.cxx
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/fltk-chess/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${S}/fltk-chess ${D}${bindir}
+ install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/{user,computer}.png \
+ ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/fltk-chess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/fltk-chess.desktop ${D}${datadir}/applications/
+}
+
+
diff --git a/recipes/gnuchess/fltk-chess_0.51.bb b/recipes/gnuchess/fltk-chess_0.51.bb
new file mode 100644
index 0000000000..512e260008
--- /dev/null
+++ b/recipes/gnuchess/fltk-chess_0.51.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
+AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
+SECTION = "x11/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk"
+RDEPENDS = "gnuchess"
+
+
+SRC_URI = "http://members.cheese.at/woody/zaurus/src/fltk-chess-${PV}.tgz"
+S = "${WORKDIR}/fltk-chess/"
+
+
+do_compile() {
+ `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
+ fltk-chess.cxx
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/fltk-chess/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${S}/fltk-chess ${D}${bindir}
+ install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/{user,computer}.png \
+ ${D}${datadir}/pixmaps/fltk-chess/
+ install -m 0644 ${S}/bitmaps/fltk-chess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${S}/fltk-chess.desktop ${D}${datadir}/applications/
+}
diff --git a/recipes/gnuchess/gnuchess_5.021.bb b/recipes/gnuchess/gnuchess_5.021.bb
new file mode 100644
index 0000000000..18c94bdab0
--- /dev/null
+++ b/recipes/gnuchess/gnuchess_5.021.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Gnuchess is a chess playing engine."
+SECTION = "console"
+PRIORITY = "optional"
+MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
+LICENSE = "GPL"
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz"
+S = "${WORKDIR}/chess-5.02/src"
+
+inherit autotools
+
+do_install() {
+ install -D ${S}/gnuchess ${D}${bindir}/gnuchess
+}
diff --git a/recipes/gnuchess/gnuchess_5.05.bb b/recipes/gnuchess/gnuchess_5.05.bb
new file mode 100644
index 0000000000..d0536c3f84
--- /dev/null
+++ b/recipes/gnuchess/gnuchess_5.05.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Gnuchess is a chess playing engine."
+HOMEPAGE = "http://www.gnu.org/software/chess/"
+SECTION = "console"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "${GNU_MIRROR}/chess/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/chess"
+
+inherit autotools