aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnuradio')
-rw-r--r--recipes/gnuradio/gnuradio.inc12
-rw-r--r--recipes/gnuradio/gnuradio_3.1.3.bb6
-rw-r--r--recipes/gnuradio/gnuradio_3.2.0.bb11
-rw-r--r--recipes/gnuradio/gnuradio_svn.bb12
4 files changed, 17 insertions, 24 deletions
diff --git a/recipes/gnuradio/gnuradio.inc b/recipes/gnuradio/gnuradio.inc
index b1c83b4ab1..85fd5a16b6 100644
--- a/recipes/gnuradio/gnuradio.inc
+++ b/recipes/gnuradio/gnuradio.inc
@@ -2,7 +2,8 @@ DESCRIPTION = "GNU Radio"
SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "guile-native fftwf python virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native python-numpy"
+DEPENDS = "libusb guile-native fftwf python virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native python-numpy"
+INC_PR = "r7"
inherit distutils-base autotools autotools_stage pkgconfig
@@ -12,6 +13,7 @@ export HOST_SYS=${MULTIMACH_TARGET_SYS}
CXXFLAGS_powerpc += "-lstdc++"
EXTRA_OECONF = " \
+ --program-prefix= \
${GR_CPU_SELECTION} \
--disable-gr-atsc \
--enable-gr-video-sdl \
@@ -43,6 +45,9 @@ do_buildlibusb() {
cd ${WORKDIR}
}
+addtask buildlibusb before do_configure after do_unpack
+
+do_buildlibusb[deptask] = "do_populate_staging"
do_configure_prepend() {
if [ -e ${WORKDIR}/acinclude.m4 ] ; then
@@ -54,6 +59,11 @@ do_configure_append() {
find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
}
+do_stage() {
+ autotools_stage_all
+ sed -i s,-l:libusb-gnur.a,,g ${STAGING_LIBDIR}/libusrp.la
+}
+
RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs python-lang python-textutils \
python-shell python-pickle python-compiler python-pkgutil python-pydoc python-mmap \
python-netclient python-unittest python-difflib python-pprint python-numpy \
diff --git a/recipes/gnuradio/gnuradio_3.1.3.bb b/recipes/gnuradio/gnuradio_3.1.3.bb
index 437e62f140..fbce7bdf74 100644
--- a/recipes/gnuradio/gnuradio_3.1.3.bb
+++ b/recipes/gnuradio/gnuradio_3.1.3.bb
@@ -1,13 +1,9 @@
require gnuradio.inc
-PR = "r4"
+PR = "${INC_PR}.1"
SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-${PV}.tar.gz \
file://acinclude.m4 \
${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
"
-# This is an awful hack to allow GNU Radio to use libusb-0.12, regardless
-# of what is used by the rest of OE
-
-addtask buildlibusb before do_configure after do_unpack
diff --git a/recipes/gnuradio/gnuradio_3.2.0.bb b/recipes/gnuradio/gnuradio_3.2.0.bb
index eef34bb03f..8c3a77e20b 100644
--- a/recipes/gnuradio/gnuradio_3.2.0.bb
+++ b/recipes/gnuradio/gnuradio_3.2.0.bb
@@ -2,11 +2,11 @@ require gnuradio.inc
DEPENDS += " gsl "
-PR = "r2"
+PR = "${INC_PR}.1"
S = "${WORKDIR}/gnuradio-3.2"
-EXTRA_OECONF += "--program-prefix= --with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable--usrp2"
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable--usrp2"
SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.tar.gz \
file://no-usrp2.patch;patch=1 \
@@ -14,13 +14,6 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/gnuradio-3.2.tar.gz \
${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
"
-# This is an awful hack to allow GNU Radio to use libusb-0.12, regardless
-# of what is used by the rest of OE
-
-addtask buildlibusb before do_configure after do_unpack
-
-do_buildlibusb[deptask] = "do_populate_staging"
-
do_compile_append() {
sed -i -e s:${STAGING_DIR_TARGET}::g \
-e s:/${TARGET_SYS}::g \
diff --git a/recipes/gnuradio/gnuradio_svn.bb b/recipes/gnuradio/gnuradio_svn.bb
index 73348bf208..dc693b78de 100644
--- a/recipes/gnuradio/gnuradio_svn.bb
+++ b/recipes/gnuradio/gnuradio_svn.bb
@@ -4,10 +4,10 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS += " gsl "
-PV = "3.1.3+svnr${SRCREV}"
-PR = "r7"
+PV = "3.2.0+svnr${SRCREV}"
+PR = "${INC_PR}.1"
-EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable-usrp1 --disable--usrp2"
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable--usrp2"
SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
file://no-usrp2.patch;patch=1 \
@@ -15,12 +15,6 @@ SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
${SOURCEFORGE_MIRROR}/libusb/libusb-0.1.12.tar.gz \
"
-# This is an awful hack to allow GNU Radio to use libusb-0.12, regardless
-# of what is used by the rest of OE
-
-addtask buildlibusb before do_configure after do_unpack
-
-
S="${WORKDIR}/trunk"
#do_configure() {