summaryrefslogtreecommitdiffstats
path: root/recipes/gobby
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gobby')
-rw-r--r--recipes/gobby/gobby_0.4.1.bb7
-rw-r--r--recipes/gobby/gtksourceview_1.7.2.bb9
-rw-r--r--recipes/gobby/net6_1.2.2.bb15
-rw-r--r--recipes/gobby/net6_1.3.1.bb14
-rw-r--r--recipes/gobby/obby_0.4.1.bb18
5 files changed, 63 insertions, 0 deletions
diff --git a/recipes/gobby/gobby_0.4.1.bb b/recipes/gobby/gobby_0.4.1.bb
new file mode 100644
index 0000000000..f9474c8fe3
--- /dev/null
+++ b/recipes/gobby/gobby_0.4.1.bb
@@ -0,0 +1,7 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "net6 gtkmm obby gtksourceview libxml++"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/gobby/gobby-${PV}.tar.gz"
diff --git a/recipes/gobby/gtksourceview_1.7.2.bb b/recipes/gobby/gtksourceview_1.7.2.bb
new file mode 100644
index 0000000000..6b4c8e686c
--- /dev/null
+++ b/recipes/gobby/gtksourceview_1.7.2.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ libgnomeprint"
+
+inherit gnome pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/gobby/net6_1.2.2.bb b/recipes/gobby/net6_1.2.2.bb
new file mode 100644
index 0000000000..5399cd57c6
--- /dev/null
+++ b/recipes/gobby/net6_1.2.2.bb
@@ -0,0 +1,15 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "libsigc++-2.0"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/net6
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/net6
+ install -m 755 .libs/*so* ${STAGING_LIBDIR}/
+}
diff --git a/recipes/gobby/net6_1.3.1.bb b/recipes/gobby/net6_1.3.1.bb
new file mode 100644
index 0000000000..bafc185322
--- /dev/null
+++ b/recipes/gobby/net6_1.3.1.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "libsigc++-2.0 gnutls"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/net6
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/net6
+ install -m 755 .libs/*so* ${STAGING_LIBDIR}/
+}
diff --git a/recipes/gobby/obby_0.4.1.bb b/recipes/gobby/obby_0.4.1.bb
new file mode 100644
index 0000000000..f72ca51ab3
--- /dev/null
+++ b/recipes/gobby/obby_0.4.1.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "net6 gtkmm gmp"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/obby/obby-${PV}.tar.gz"
+
+EXTRA_OECONF += " --with-libgmp-prefix=${STAGING_LIBDIR}"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/obby
+ install -d ${STAGING_INCDIR}/obby/serialise
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/obby
+ install -m 644 inc/serialise/*.hpp ${STAGING_INCDIR}/obby/serialise
+ install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
+}