aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb b/recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
new file mode 100644
index 0000000000..293766a0b6
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "An Enlightenment theme for gpe-bootsplash"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gpe-bootsplash"
+RDEPENDS = "gpe-bootsplash"
+PR = "r1"
+
+export THEME = "opie"
+
+SRC_URI = "file://*.svg \
+ file://*${THEME}*logo*"
+
+#FIXME: please use $datadir instead of /usr/share
+#FIXME: please use an gpe-bootsplash-theme.inc to reduce duplication
+
+do_install(){
+ install -d "${D}/usr/share/gpe"
+ install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}/usr/share/gpe
+ install -m 0644 ${WORKDIR}/${THEME}-logo.png ${D}/usr/share/gpe
+}
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg 20
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg 20
+}
+
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
+}
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-* \
+ /usr/share/gpe/${THEME}-logo.png"
+