aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb b/recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb
new file mode 100644
index 0000000000..6f54eadad0
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash_1.13.bb
@@ -0,0 +1,18 @@
+inherit gpe
+
+DEPENDS = "gtk+ librsvg"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI += "file://splash-p.svg file://splash-l.svg"
+
+FILES_${PN} += "${datadir}/gpe"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S02bootsplash
+}
+