aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-fsi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-fsi')
-rw-r--r--recipes/gpe-fsi/gpe-fsi_0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/gpe-fsi/gpe-fsi_0.1.bb b/recipes/gpe-fsi/gpe-fsi_0.1.bb
new file mode 100644
index 0000000000..479308d64c
--- /dev/null
+++ b/recipes/gpe-fsi/gpe-fsi_0.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GPE frontend for libfsi-client"
+LICENSE = "gpl"
+
+inherit gpe
+
+SRC_URI = "http://dominion.kabel.utwente.nl/koen/pda/files/gpe-fsi.tar.bz2"
+PR = "r1"
+
+DEPENDS = "libgpewidget fsi-client gtk+"
+SECTION = "gpe"
+
+S ="${WORKDIR}/gpe-fsi"
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}/usr/share/applications
+ install -d ${D}/usr/share/pixmaps/
+ install gpe-fsi ${D}${bindir}
+ install gpe-fsi.desktop ${D}/usr/share/applications/
+ install gpe-fsi.png ${D}/usr/share/pixmaps/
+}
+