aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb')
-rw-r--r--recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb b/recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb
new file mode 100644
index 0000000000..488e32f55b
--- /dev/null
+++ b/recipes/gpe-sketchbook/gpe-sketchbook_0.2.9.bb
@@ -0,0 +1,22 @@
+DEPENDS = "libgpewidget sqlite"
+LICENSE = "GPL"
+DESCRIPTION = "A GPE notebook to sketch your notes"
+export CVSBUILD = "no"
+
+inherit gpe pkgconfig
+
+CFLAGS +="-D_GNU_SOURCE"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN} += " ${datadir}/gpe/pixmaps"
+
+do_compile () {
+ oe_runmake PREFIX=${prefix}
+ oe_runmake all-desktop PREFIX=${prefix}
+}
+
+do_install () {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-program
+}