summaryrefslogtreecommitdiffstats
path: root/recipes/gpe-watch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-watch')
-rw-r--r--recipes/gpe-watch/gpe-watch-0.10/fix_install.patch13
-rw-r--r--recipes/gpe-watch/gpe-watch_0.10.bb5
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
new file mode 100644
index 0000000000..3ae63a839f
--- /dev/null
+++ b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
@@ -0,0 +1,13 @@
+diff --git gpe-watch-0.10/Makefile-orig gpe-watch-0.10/Makefile
+index 2f74616..58fa802 100644
+--- gpe-watch-0.10/Makefile-orig
++++ gpe-watch-0.10/Makefile
+@@ -39,7 +39,7 @@ $(PACKAGE): $(OBJS) $(LIB)
+
+ install-program: all $(PACKAGE).desktop
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ #mkdir -p $(DESTDIR)$(PREFIX)/share/$(PACKAGE)
diff --git a/recipes/gpe-watch/gpe-watch_0.10.bb b/recipes/gpe-watch/gpe-watch_0.10.bb
index e0d514701c..9b386a2755 100644
--- a/recipes/gpe-watch/gpe-watch_0.10.bb
+++ b/recipes/gpe-watch/gpe-watch_0.10.bb
@@ -1,5 +1,6 @@
LICENSE = "GPL"
inherit gpe pkgconfig
+PR = "r1"
DESCRIPTION = "GPE analog clock-watch"
DEPENDS = "gtk+ libgpewidget"
@@ -7,4 +8,6 @@ SECTION = "gpe"
PRIORITY = "optional"
SRC_URI += "file://fix_makefile.patch;patch=1 \
- file://no-render-h.patch;patch=1"
+ file://fix_install.patch;patch=1 \
+ file://no-render-h.patch;patch=1 \
+ "