aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-what/gpe-what-0.33/makefile-fix.patch')
-rw-r--r--recipes/gpe-what/gpe-what-0.33/makefile-fix.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
new file mode 100644
index 0000000000..3e48d63465
--- /dev/null
+++ b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
@@ -0,0 +1,21 @@
+--- gpe-what-0.33/Makefile.orig 2005-11-03 21:41:33 +0100
++++ gpe-what-0.33/Makefile 2005-11-03 21:45:10 +0100
+@@ -6,16 +6,14 @@
+
+ MEMBERS = gpe-what mbtray
+
+-PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS)
+-PACKAGE_LDFLAGS += $(GTKLDFLAGS)
++PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS) `pkg-config --cflags libmb`
++PACKAGE_LDFLAGS += $(GTKLDFLAGS) `pkg-config --libs libmb`
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+
+ OBJS = $(patsubst %,%.o,$(MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS))
+
+-PACKAGE_LDFLAGS += -lmb
+-
+ ifeq ($(CVSBUILD),yes)
+ BUILD = ../build
+ else