aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/gpe-applauncher_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/gpe-applauncher_0.11.bb')
-rw-r--r--recipes/gpephone/gpe-applauncher_0.11.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gpephone/gpe-applauncher_0.11.bb b/recipes/gpephone/gpe-applauncher_0.11.bb
new file mode 100644
index 0000000000..4934cdeaf2
--- /dev/null
+++ b/recipes/gpephone/gpe-applauncher_0.11.bb
@@ -0,0 +1,29 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cellphone application launcher."
+SECTION = "gpe"
+PRIORITY = "optional"
+PR = "r2"
+
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
+
+PACKAGES += "gpe-applauncher-config"
+PACKAGE_ARCH_gpe-applauncher-config_om-gta01 = "${MACHINE_ARCH}"
+
+DEPENDS = "gtk+ libgpewidget libgpephone libgpelaunch dbus-glib libsettings libxsettings-client"
+RDEPENDS_${PN} += "gpe-applauncher-config"
+
+GPE_TARBALL_SUFFIX= "bz2"
+inherit gpephone autotools
+
+SRC_URI += "file://hotkeys.conf \
+ file://softkeys.conf"
+
+EXTRA_OECONF = "--enable-gridlayout"
+
+FILES_${PN} = '${datadir} ${bindir}'
+FILES_gpe-applauncher-config = '${sysconfdir}/gpe/'
+
+do_configure_append () {
+ install ${WORKDIR}/hotkeys.conf ${S}
+ install ${WORKDIR}/softkeys.conf ${S}
+}