aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libabenabler2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libabenabler2_svn.bb')
-rw-r--r--recipes/gpephone/libabenabler2_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gpephone/libabenabler2_svn.bb b/recipes/gpephone/libabenabler2_svn.bb
new file mode 100644
index 0000000000..004ba3ec46
--- /dev/null
+++ b/recipes/gpephone/libabenabler2_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "LiPS address book library."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "glib-2.0 librecord2 gconf sqlite3"
+PV = "0.0+svnr-${SRCREV}"
+PR = "r0"
+
+inherit gpephone pkgconfig autotools
+
+SRC_URI = "${GPEPHONE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_stage () {
+ autotools_stage_all
+}
+
+DEFAULT_PREFERENCE = "-1"
+
+LDFLAGS += " -L${STAGING_LIBDIR}"