aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libiac2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libiac2_svn.bb')
-rw-r--r--recipes/gpephone/libiac2_svn.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/gpephone/libiac2_svn.bb b/recipes/gpephone/libiac2_svn.bb
new file mode 100644
index 0000000000..7ae0c7b693
--- /dev/null
+++ b/recipes/gpephone/libiac2_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "LiPS IPC library."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+LICENSE = "LiPS"
+DEPENDS = "gtk+ gtk-doc dbus-glib"
+PV = "0.0+svnr-${SRCREV}"
+PR = "r0"
+
+inherit gpephone pkgconfig autotools
+
+SRC_URI = "${GPEPHONE_SVN} \
+ file://disable-tests.patch;patch=1;pnum=0"
+
+EXTRA_OECONF = "--enable-gui --enable-test=no --with-cuint=no"
+
+S = ${WORKDIR}/${PN}
+
+do_stage () {
+ autotools_stage_all
+}