aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libidn_0.5.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libidn_0.5.19.bb')
-rw-r--r--recipes/gpephone/libidn_0.5.19.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/gpephone/libidn_0.5.19.bb b/recipes/gpephone/libidn_0.5.19.bb
new file mode 100644
index 0000000000..322790b8ab
--- /dev/null
+++ b/recipes/gpephone/libidn_0.5.19.bb
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+inherit pkgconfig autotools
+
+SRC_URI = "http://josefsson.org/libidn/releases/${P}.tar.gz"
+
+EXTRA_OECONF = " --disable-tld"
+
+do_configure_prepend () {
+ autoreconf -f -i -s
+}
+
+do_stage () {
+ autotools_stage_all
+}