aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libim_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libim_0.2.bb')
-rw-r--r--recipes/gpephone/libim_0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gpephone/libim_0.2.bb b/recipes/gpephone/libim_0.2.bb
new file mode 100644
index 0000000000..7a42d49284
--- /dev/null
+++ b/recipes/gpephone/libim_0.2.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+DESCRIPTION = "LiPS instant messenger library."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0 libgpg-error libgcrypt gnutls libidn iksemel gloox dbus-glib liblipsevent"
+PR = "r1"
+
+inherit gpephone pkgconfig autotools
+
+SRC_URI = "${GPEPHONE_MIRROR}/${P}/lips_im-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-session-bus-services-dir=${datadir}/dbus-1/services"
+
+PARALLEL_MAKE = ""
+
+S = ${WORKDIR}/lips_im-${PV}
+
+FILES_${PN} += " ${datadir}/dbus-1"
+
+do_stage () {
+ autotools_stage_all
+}