aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpesyncd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpesyncd')
-rw-r--r--recipes/gpesyncd/gpe-synctool_0.2.bb8
-rw-r--r--recipes/gpesyncd/gpe-synctool_svn.bb15
-rw-r--r--recipes/gpesyncd/gpesyncd_2.0.bb12
-rw-r--r--recipes/gpesyncd/gpesyncd_svn.bb15
4 files changed, 50 insertions, 0 deletions
diff --git a/recipes/gpesyncd/gpe-synctool_0.2.bb b/recipes/gpesyncd/gpe-synctool_0.2.bb
new file mode 100644
index 0000000000..5db87ad995
--- /dev/null
+++ b/recipes/gpesyncd/gpe-synctool_0.2.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Sync daemon for GPE and OpenSync"
+LICENSE = "GPL"
+DEPENDS = "gtk+ glib-2.0 libgpewidget"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools
+
diff --git a/recipes/gpesyncd/gpe-synctool_svn.bb b/recipes/gpesyncd/gpe-synctool_svn.bb
new file mode 100644
index 0000000000..e85013c117
--- /dev/null
+++ b/recipes/gpesyncd/gpe-synctool_svn.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Sync daemon for GPE and OpenSync"
+LICENSE = "GPL"
+DEPENDS = "gtk+ glib-2.0 libgpewidget"
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.2+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
diff --git a/recipes/gpesyncd/gpesyncd_2.0.bb b/recipes/gpesyncd/gpesyncd_2.0.bb
new file mode 100644
index 0000000000..69e0a677ec
--- /dev/null
+++ b/recipes/gpesyncd/gpesyncd_2.0.bb
@@ -0,0 +1,12 @@
+LICENSE = "GPL"
+DESCRIPTION = "Sync daemon for GPE and OpenSync"
+
+DEPENDS = "libgpevtype libtododb libcontactsdb libeventdb sqlite libmimedir glib-2.0"
+
+PR = "r0"
+
+GPE_TARBALL_SUFFIX="bz2"
+inherit autotools gpe
+
+FILES_${PN} += "${datadir}/gpe"
+
diff --git a/recipes/gpesyncd/gpesyncd_svn.bb b/recipes/gpesyncd/gpesyncd_svn.bb
new file mode 100644
index 0000000000..c7adad7340
--- /dev/null
+++ b/recipes/gpesyncd/gpesyncd_svn.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+DESCRIPTION = "Sync daemon for GPE and OpenSync"
+
+SRC_URI = "${GPE_SVN}"
+
+DEPENDS = "libgpevtype libtododb libcontactsdb libeventdb sqlite libmimedir glib-2.0"
+
+S = "${WORKDIR}/${PN}"
+PV = "0.0+svn${SRCDATE}"
+PR = "r0"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/gpe"
+