aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/grep/grep_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/grep/grep_2.5.1.bb')
-rw-r--r--recipes/grep/grep_2.5.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/grep/grep_2.5.1.bb b/recipes/grep/grep_2.5.1.bb
new file mode 100644
index 0000000000..6d184b8c4c
--- /dev/null
+++ b/recipes/grep/grep_2.5.1.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
+ file://uclibc-fix.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}