aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/groff/groff_1.19.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/groff/groff_1.19.2.bb')
-rw-r--r--recipes/groff/groff_1.19.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/groff/groff_1.19.2.bb b/recipes/groff/groff_1.19.2.bb
new file mode 100644
index 0000000000..62f56a8c27
--- /dev/null
+++ b/recipes/groff/groff_1.19.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU roff"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r4"
+
+SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
+ file://Makefile.in.patch;patch=1 \
+ file://Makefile.sub.patch;patch=1 \
+ file://groff.patch;patch=1"
+
+PARALLEL_MAKE = ""
+# prefix and exec-prefix are broken and the .in file is broken too
+# and can't be autoreconf'ed, so specify every dir
+EXTRA_OECONF="--prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}/info --with-appresdir=${D}${datadir}"
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+#
+# The installer refuses to do anything if the prefix directory does not
+# already exist, so create it manually before the standard install runs.
+#
+do_install_prepend() {
+ install -m 0755 -d ${D}
+}