aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap/gsoap_2.7.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gsoap/gsoap_2.7.7.bb')
-rw-r--r--recipes/gsoap/gsoap_2.7.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gsoap/gsoap_2.7.7.bb b/recipes/gsoap/gsoap_2.7.7.bb
new file mode 100644
index 0000000000..dc6ff6e320
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.7.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
+for the development of SOAP Web Services and clients."
+SECTION = "devel"
+LICENSE = "GPL"
+DEPENDS = "gsoap-native"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gsoap2/gsoap_${PV}.tar.gz"
+S = "${WORKDIR}/gsoap-2.7"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C soapcpp2 $lib ${D}${libdir}
+ done
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN} ${PN}-doc ${PN}-locale"
+FILES_gsoap-dev = "${bindir}/wsdl2h ${bindir}/soapcpp2 ${libdir}"