summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-webcore/osb-nrcore_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk-webcore/osb-nrcore_svn.bb')
-rw-r--r--recipes/gtk-webcore/osb-nrcore_svn.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gtk-webcore/osb-nrcore_svn.bb b/recipes/gtk-webcore/osb-nrcore_svn.bb
new file mode 100644
index 0000000000..b85c06e422
--- /dev/null
+++ b/recipes/gtk-webcore/osb-nrcore_svn.bb
@@ -0,0 +1,23 @@
+require osb-nrcore.inc
+
+PV = "0.5.2+svnr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "svn://gtk-webcore.svn.sourceforge.net/svnroot/gtk-webcore/trunk;module=NRCore;proto=https \
+ file://gcc4-fno-threadsafe-statics-NRCore.patch;patch=1 \
+ file://build_silence.patch;patch=0;maxdate=20070401 \
+ file://path_fixes.patch;patch=1"
+
+S = "${WORKDIR}/NRCore"
+
+do_stage () {
+ oe_libinstall -so libgtk_webcore_nrcore ${STAGING_LIBDIR}
+ oe_libinstall -so -C kwiq libgtk_webcore_nrcore_kwiq_gtk ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+
+ install -d ${STAGING_INCDIR}/osb/NRCore
+ for i in ${S}/kwiq/WebCore*.h ${S}/kwiq/KWIQ*.h; do
+ install -m 0644 $i ${STAGING_INCDIR}/osb/NRCore
+ done
+}