summaryrefslogtreecommitdiffstats
path: root/recipes/gtk2-ssh-askpass
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk2-ssh-askpass')
-rw-r--r--recipes/gtk2-ssh-askpass/gtk2-ssh-askpass/makefile.patch19
-rw-r--r--recipes/gtk2-ssh-askpass/gtk2-ssh-askpass_0.3.bb20
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass/makefile.patch b/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass/makefile.patch
new file mode 100644
index 0000000000..4f9eb4700d
--- /dev/null
+++ b/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass/makefile.patch
@@ -0,0 +1,19 @@
+--- gtk2-ssh-askpass-0.3/Makefile 2003-03-07 06:47:38.000000000 -0700
++++ gtk2-ssh-askpass-0.3.new/Makefile 2004-07-13 11:16:07.242199368 -0700
+@@ -1,5 +1,13 @@
++CC=gcc
++CFLAGS=-O2
++
++GTK_CFLAGS := `pkg-config --cflags gtk+-2.0`
++
++LDFLAGS=
++GTK_LDFLAGS := `pkg-config --libs gtk+-2.0`
++
+ all:
+- gcc -o gtk2-ssh-askpass gtk2-ssh-askpass.c `pkg-config --libs gtk+-2.0` `pkg-config --cflags gtk+-2.0`
++ $(CC) -o gtk2-ssh-askpass $(CFLAGS) $(GTK_CFLAGS) gtk2-ssh-askpass.c $(LDFLAGS) $(GTK_LDFLAGS)
+
+ clean:
+- rm gtk2-ssh-askpass
+\ No newline at end of file
++ rm gtk2-ssh-askpass
diff --git a/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass_0.3.bb b/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass_0.3.bb
new file mode 100644
index 0000000000..3c4eb9a530
--- /dev/null
+++ b/recipes/gtk2-ssh-askpass/gtk2-ssh-askpass_0.3.bb
@@ -0,0 +1,20 @@
+# gtk2-ssh-askpass OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="GTK2 ssh askpass utility"
+HOMEPAGE="http://www.cgabriel.org/sw/gtk2-ssh-askpass/"
+LICENSE = "GPL"
+SECTION = "network/misc"
+
+SRC_URI="http://src.gentoo.pl/distfiles/gtk2-ssh-askpass-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+DEPENDS="gtk+"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libexecdir}
+ cp ${S}/gtk2-ssh-askpass ${D}${bindir}
+ ln -s ${bindir}/gtk2-ssh-askpass ${D}${libexecdir}/ssh-askpass
+}