summaryrefslogtreecommitdiffstats
path: root/recipes/handsfree
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/handsfree')
-rw-r--r--recipes/handsfree/files/Makefile.patch19
-rw-r--r--recipes/handsfree/handsfree_0.1.bb32
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/handsfree/files/Makefile.patch b/recipes/handsfree/files/Makefile.patch
new file mode 100644
index 0000000000..6ca8dd2698
--- /dev/null
+++ b/recipes/handsfree/files/Makefile.patch
@@ -0,0 +1,19 @@
+--- handsfree/old/Makefile 2006-11-21 18:01:13.000000000 +0000
++++ handsfree/Makefile 2006-11-21 14:01:17.000000000 +0000
+@@ -9,12 +9,12 @@
+ # I use a dmixer as default alsa device to mix
+ # the handsfree output with other sound playback
+ #
+-ALSA_PLAY="default"
+-ALSA_REC="plughw:0,0"
++#ALSA_PLAY="default"
++#ALSA_REC="plughw:0,0"
+
+
+-LDFLAGS= -lbluetooth -lasound
+-CFLAGS=-g -Wall -DOSS=0
++#LDFLAGS= -lbluetooth -lasound
++#CFLAGS=-g -Wall -DOSS=0
+
+ all: handsfree headset
+
diff --git a/recipes/handsfree/handsfree_0.1.bb b/recipes/handsfree/handsfree_0.1.bb
new file mode 100644
index 0000000000..bd909a0140
--- /dev/null
+++ b/recipes/handsfree/handsfree_0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Handsfree and Handset Bluetooth tool"
+HOMEPAGE = "http://www.soft.uni-linz.ac.at/_wiki/tiki-index.php?page=ProjectBluezHandsfree"
+SECTION = "network/misc"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS= "bluez-libs alsa-lib"
+PR = "r0"
+
+
+SRC_URI = "\
+ http://www.soft.uni-linz.ac.at/~vogl/bluez/handsfree-040326.tar.gz \
+ file://Makefile.patch;patch=1 \
+"
+S = "${WORKDIR}/handsfree"
+
+# Alsa devices
+# Example: "plughw:0,0"
+ALSA_PLAY = "default"
+ALSA_REC = "default"
+
+CFLAGS =+ "-DOSS=0 "
+LDFLAGS =+ "-lbluetooth -lasound "
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 handsfree ${D}${bindir}
+ install -m 0755 headset ${D}${bindir}
+}