aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hibernate-script/hibernate-script_1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hibernate-script/hibernate-script_1.12.bb')
-rw-r--r--recipes/hibernate-script/hibernate-script_1.12.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/hibernate-script/hibernate-script_1.12.bb b/recipes/hibernate-script/hibernate-script_1.12.bb
new file mode 100644
index 0000000000..3d6f428d90
--- /dev/null
+++ b/recipes/hibernate-script/hibernate-script_1.12.bb
@@ -0,0 +1,38 @@
+# hibernate-script OE build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+LICENSE="GPL"
+HOMEPAGE="http://www.suspend2.net"
+
+SRC_URI="http://www.suspend2.net/downloads/all/${PN}-${PV}.tar.gz \
+ file://hibernate.conf \
+ file://standby.conf \
+ file://ram.conf"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "hibernate-cleanup"
+INITSCRIPT_PARAMS = "start 31 S ."
+
+FILES_${PN}_append = " /usr/share/hibernate"
+
+do_install () {
+ BASE_DIR=${D} PREFIX=/usr MAN_DIR=${D}/usr/share/man \
+ ${S}/install.sh
+
+ ln -s ./hibernate ${D}/usr/sbin/hibernate-standby
+ ln -s ./hibernate ${D}/usr/sbin/hibernate-ram
+
+ #Override conf files from ${WORKDIR}
+ install -m 0644 ${WORKDIR}/hibernate.conf ${D}/etc/hibernate/
+ install -m 0644 ${WORKDIR}/ram.conf ${D}/etc/hibernate/
+ install -m 0644 ${WORKDIR}/standby.conf ${D}/etc/hibernate/
+
+ install -d ${D}/etc/init.d
+ install -m 0755 ${S}/init.d/hibernate-cleanup.sh ${D}/etc/init.d/hibernate-cleanup
+
+}
+
+