summaryrefslogtreecommitdiffstats
path: root/recipes/hostap
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hostap')
-rw-r--r--recipes/hostap/hostap-utils-0.4.7/ldflags.patch24
-rw-r--r--recipes/hostap/hostap-utils_0.4.7.bb24
2 files changed, 47 insertions, 1 deletions
diff --git a/recipes/hostap/hostap-utils-0.4.7/ldflags.patch b/recipes/hostap/hostap-utils-0.4.7/ldflags.patch
new file mode 100644
index 0000000000..d2ca2980db
--- /dev/null
+++ b/recipes/hostap/hostap-utils-0.4.7/ldflags.patch
@@ -0,0 +1,24 @@
+diff -urN hostap-utils-0.4.7.orig/Makefile hostap-utils-0.4.7/Makefile
+--- hostap-utils-0.4.7.orig/Makefile 2005-01-01 06:42:51.000000000 +0000
++++ hostap-utils-0.4.7/Makefile 2009-04-08 08:36:46.000000000 +0000
+@@ -14,17 +14,17 @@
+ hostap_crypt_conf: hostap_crypt_conf.c
+
+ hostap_diag: hostap_diag.o util.o
+- $(CC) -o hostap_diag $(CFLAGS) hostap_diag.o util.o
++ $(CC) -o hostap_diag $(CFLAGS) $(LDFLAGS) hostap_diag.o util.o
+
+ hostap_diag.o: hostap_diag.c util.h
+
+ util.o: util.c util.h
+
+ hostap_io_debug: hostap_io_debug.c
+- $(CC) -o hostap_io_debug $(CFLAGS) hostap_io_debug.c
++ $(CC) -o hostap_io_debug $(CFLAGS) $(LDFLAGS) hostap_io_debug.c
+
+ hostap_rid: hostap_rid.o util.o
+- $(CC) -o hostap_rid $(CFLAGS) hostap_rid.o util.o
++ $(CC) -o hostap_rid $(CFLAGS) $(LDFLAGS) hostap_rid.o util.o
+
+ hostap_rid.o: hostap_rid.c util.h
+
diff --git a/recipes/hostap/hostap-utils_0.4.7.bb b/recipes/hostap/hostap-utils_0.4.7.bb
index 9fe362b19f..563594780d 100644
--- a/recipes/hostap/hostap-utils_0.4.7.bb
+++ b/recipes/hostap/hostap-utils_0.4.7.bb
@@ -1 +1,23 @@
-require hostap-utils.inc
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}