summaryrefslogtreecommitdiffstats
path: root/recipes/hostap
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hostap')
-rw-r--r--recipes/hostap/files/hostap-no-bsd.patch19
-rw-r--r--recipes/hostap/hostap-daemon_0.4.4.bb4
-rw-r--r--recipes/hostap/hostap-daemon_0.5.10.bb4
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes/hostap/files/hostap-no-bsd.patch b/recipes/hostap/files/hostap-no-bsd.patch
new file mode 100644
index 0000000000..c40d98c959
--- /dev/null
+++ b/recipes/hostap/files/hostap-no-bsd.patch
@@ -0,0 +1,19 @@
+--- hostapd-0.4.4/driver_madwifi.c-orig 2008-04-16 15:11:49.000000000 +0200
++++ hostapd-0.4.4/driver_madwifi.c 2008-04-16 15:10:38.000000000 +0200
+@@ -26,14 +26,14 @@
+ #include <net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+ /* Assume this is built against BSD branch of madwifi driver. */
+-#define MADWIFI_BSD
++/*#define MADWIFI_BSD*/
++#include <linux/wireless.h>
+ #include <net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
+
+ #include <net/if_arp.h>
+-#include <linux/wireless.h>
+
+ #include <netinet/in.h>
+ #include <netpacket/packet.h>
diff --git a/recipes/hostap/hostap-daemon_0.4.4.bb b/recipes/hostap/hostap-daemon_0.4.4.bb
index bece7d1450..83a5386f3a 100644
--- a/recipes/hostap/hostap-daemon_0.4.4.bb
+++ b/recipes/hostap/hostap-daemon_0.4.4.bb
@@ -1,3 +1,7 @@
require hostap-daemon.inc
+SRC_URI_append_nylon = "\
+ file://hostap-no-bsd.patch;patch=1"
+
+
PR = "r2"
diff --git a/recipes/hostap/hostap-daemon_0.5.10.bb b/recipes/hostap/hostap-daemon_0.5.10.bb
index 3fc1d8dc11..ea493017fe 100644
--- a/recipes/hostap/hostap-daemon_0.5.10.bb
+++ b/recipes/hostap/hostap-daemon_0.5.10.bb
@@ -5,6 +5,10 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "openssl ${@base_contains("COMBINED_FEATURES", "pci", "madwifi-ng", "",d)}"
PR = "r1"
+DEPENDS_append_mtx-1 = " madwifi-modules"
+DEPENDS_append_mtx-2 = " madwifi-modules"
+CPPFLAGS_append_mtx-1 = " -I${STAGING_INCDIR}/madwifi/"
+CPPFLAGS_append_mtx-2 = " -I${STAGING_INCDIR}/madwifi/"
#we introduce MY_ARCH to get 'armv5te' as arch instead of the misleading 'arm' on armv5te builds
MY_ARCH := "${PACKAGE_ARCH}"