aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hotplug-ng/hotplug-ng_002.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hotplug-ng/hotplug-ng_002.bb')
-rw-r--r--recipes/hotplug-ng/hotplug-ng_002.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/hotplug-ng/hotplug-ng_002.bb b/recipes/hotplug-ng/hotplug-ng_002.bb
new file mode 100644
index 0000000000..3c5014be9a
--- /dev/null
+++ b/recipes/hotplug-ng/hotplug-ng_002.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz"
+
+#S = "${WORKDIR}/hotplug-ng-${PV}"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+CFLAGS = " -I${S}/libsysfs/sysfs"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}