aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hotplug-qcop
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hotplug-qcop')
-rw-r--r--recipes/hotplug-qcop/hotplug-qcop_cvs.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/hotplug-qcop/hotplug-qcop_cvs.bb b/recipes/hotplug-qcop/hotplug-qcop_cvs.bb
new file mode 100644
index 0000000000..5c0d238453
--- /dev/null
+++ b/recipes/hotplug-qcop/hotplug-qcop_cvs.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "HotPlug -> QCOP Event Bridge"
+SECTION = "opie/base"
+RDEPENDS = "opie-qcop hotplug"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/core/tools/hotplug-qcop"
+S = "${WORKDIR}/hotplug-qcop"
+
+inherit opie
+
+sbindir="/sbin"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 hotplug-qcop ${D}${sbindir}
+
+ install -d ${D}${sysconfdir}/hotplug.d/default/
+ ln -sf /sbin/hotplug-qcop ${D}${sysconfdir}/hotplug.d/default/11-qcop.hotplug
+}
+
+FILES_${PN} = "${sysconfdir} ${sbindir}"