aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/howl/howl-1.0.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/howl/howl-1.0.0')
-rw-r--r--recipes/howl/howl-1.0.0/configure.patch11
-rw-r--r--recipes/howl/howl-1.0.0/posix.patch20
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/howl/howl-1.0.0/configure.patch b/recipes/howl/howl-1.0.0/configure.patch
new file mode 100644
index 0000000000..a1c0c2b57e
--- /dev/null
+++ b/recipes/howl/howl-1.0.0/configure.patch
@@ -0,0 +1,11 @@
+--- configure.ac.old 2005-05-20 14:36:48.000000000 +0100
++++ configure.ac 2005-05-20 14:36:54.000000000 +0100
+@@ -25,7 +25,7 @@
+ HOWL_LIB_OBJECTS='posix_salt.lo posix_socket.lo posix_time.lo posix_signal.lo posix_interface.lo notosx_mdns_stub.lo'
+ MDNSRESPONDER_LIB_SUBDIRS="Posix"
+ MDNSRESPONDER_LIB_OBJECTS='posix_mdns.lo'
+- AUTOIPD_EXTRA_OBJECTS='$(top_builddir)/src/autoipd/linux_autoip.lo $(top_builddir)/src/autoipd/posix_main.lo'
++ AUTOIPD_EXTRA_OBJECTS='$(top_builddir)/src/autoipd/linux_autoip.o $(top_builddir)/src/autoipd/posix_main.o'
+ PLATFORM_LIBS=-lpthread
+ HOWL_MAN_PAGES='mDNSResponder.8 autoipd.8 nifd.8'
+ ;;
diff --git a/recipes/howl/howl-1.0.0/posix.patch b/recipes/howl/howl-1.0.0/posix.patch
new file mode 100644
index 0000000000..f4dd7d349c
--- /dev/null
+++ b/recipes/howl/howl-1.0.0/posix.patch
@@ -0,0 +1,20 @@
+--- src/lib/howl/Posix/posix_interface.c.old 2005-05-20 14:26:34.000000000 +0100
++++ src/lib/howl/Posix/posix_interface.c 2005-05-20 14:26:35.000000000 +0100
+@@ -37,10 +37,16 @@
+ #include <stdio.h>
+
+ #if defined(__linux__)
+-typedef unsigned long long u64;
++typedef __uint64_t u64;
+ typedef __uint32_t u32;
+ typedef __uint16_t u16;
+ typedef __uint8_t u8;
++
++typedef __uint64_t __u64;
++typedef __uint32_t __u32;
++typedef __uint16_t __u16;
++typedef __uint8_t __u8;
++
+ # include <linux/sockios.h>
+ # include <linux/ethtool.h>
+ #endif