aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/howl/howl_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/howl/howl_1.0.0.bb')
-rw-r--r--recipes/howl/howl_1.0.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/howl/howl_1.0.0.bb b/recipes/howl/howl_1.0.0.bb
new file mode 100644
index 0000000000..9acc33018c
--- /dev/null
+++ b/recipes/howl/howl_1.0.0.bb
@@ -0,0 +1,28 @@
+SRC_URI = "http://www.porchdogsoft.com/download/howl-${PV}.tar.gz \
+ file://posix.patch;patch=1;pnum=0 \
+ file://configure.patch;patch=1;pnum=0 \
+ file://mdnsresponder.init"
+LICENSE = "howl"
+
+PR = "r2"
+
+INITSCRIPT_NAME = "mdnsresponder"
+INITSCRIPT_PARAMS = "defaults"
+
+PACKAGES += "libhowl libmdnsresponder"
+
+FILES_${PN} = "${bindir} ${sbindir} ${sysconfdir}"
+FILES_libhowl = "${libdir}/libhowl.so.*"
+FILES_libmdnsresponder = "${libdir}/libmDNSResponder.so.*"
+FILES_${PN}-doc += "${datadir}/howl/help"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/mdnsresponder.init ${D}${sysconfdir}/init.d/mdnsresponder
+ # Debian puts it here, so let's do the same
+ mv ${D}${bindir}/mDNSResponder ${D}${sbindir}
+}
+
+inherit autotools update-rc.d
+