aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/httppc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/httppc')
-rw-r--r--recipes/httppc/httppc-0.8.5/install.patch32
-rw-r--r--recipes/httppc/httppc_0.8.5.bb13
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/httppc/httppc-0.8.5/install.patch b/recipes/httppc/httppc-0.8.5/install.patch
new file mode 100644
index 0000000000..eba5944de1
--- /dev/null
+++ b/recipes/httppc/httppc-0.8.5/install.patch
@@ -0,0 +1,32 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- httppc-0.8.5/Makefile.am~install
++++ httppc-0.8.5/Makefile.am
+@@ -28,7 +28,7 @@
+ EXTRA_DIST = run proxed httppcrc
+
+ install-exec-hook:
+- (cd $(bindir) && for i in telnetx ftpx cvsx sshx scpx sftpx ; do $(LN_S) -f proxed $$i; done)
++ (cd $(DESTDIR)$(bindir) && for i in telnetx ftpx cvsx sshx scpx sftpx ; do $(LN_S) -f proxed $$i; done)
+
+ uninstall-local:
+- (cd $(bindir) && rm -f telnetx ftpx cvsx sshx scpx sftpx)
++ (cd $(DESTDIR)$(bindir) && rm -f telnetx ftpx cvsx sshx scpx sftpx)
+--- httppc-0.8.5/Makefile.in~install
++++ httppc-0.8.5/Makefile.in
+@@ -747,10 +747,10 @@
+
+
+ install-exec-hook:
+- (cd $(bindir) && for i in telnetx ftpx cvsx sshx scpx sftpx ; do $(LN_S) -f proxed $$i; done)
++ (cd $(DESTDIR)$(bindir) && for i in telnetx ftpx cvsx sshx scpx sftpx ; do $(LN_S) -f proxed $$i; done)
+
+ uninstall-local:
+- (cd $(bindir) && rm -f telnetx ftpx cvsx sshx scpx sftpx)
++ (cd $(DESTDIR)$(bindir) && rm -f telnetx ftpx cvsx sshx scpx sftpx)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/recipes/httppc/httppc_0.8.5.bb b/recipes/httppc/httppc_0.8.5.bb
new file mode 100644
index 0000000000..5dd5742686
--- /dev/null
+++ b/recipes/httppc/httppc_0.8.5.bb
@@ -0,0 +1,13 @@
+SECTION = "console/network"
+DEPENDS = "adns"
+DESCRIPTION = "HTTP Proxy Client is a set of libraries and scripts \
+that provide transparent access to Internet via HTTP proxy tunnel \
+for programs which use TCP/IP for communication. The tunnel is \
+provided by the CONNECT method of HTTP proxy, and supports external \
+DNS resolution."
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/httppc/httppc-${PV}.tar.gz \
+ file://install.patch;patch=1"
+
+inherit autotools