aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hugs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hugs')
-rw-r--r--recipes/hugs/files/hugs.desktop8
-rw-r--r--recipes/hugs/files/hugs.pngbin0 -> 439 bytes
-rw-r--r--recipes/hugs/hugs_hugs98-Nov2003.bb31
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes/hugs/files/hugs.desktop b/recipes/hugs/files/hugs.desktop
new file mode 100644
index 0000000000..1ff406394a
--- /dev/null
+++ b/recipes/hugs/files/hugs.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Hugs
+Comment=Hugs Haskell interpreter
+Exec=x-terminal-emulator -e hugs
+Terminal=0
+Type=Application
+Icon=hugs.png
+Categories=Programming
diff --git a/recipes/hugs/files/hugs.png b/recipes/hugs/files/hugs.png
new file mode 100644
index 0000000000..340ec67ed2
--- /dev/null
+++ b/recipes/hugs/files/hugs.png
Binary files differ
diff --git a/recipes/hugs/hugs_hugs98-Nov2003.bb b/recipes/hugs/hugs_hugs98-Nov2003.bb
new file mode 100644
index 0000000000..0269e7c4cb
--- /dev/null
+++ b/recipes/hugs/hugs_hugs98-Nov2003.bb
@@ -0,0 +1,31 @@
+DEPENDS = "readline"
+SRC_URI = "http://cvs.haskell.org/Hugs/downloads/Nov2003/${PV}.tar.gz \
+ file://hugs.desktop \
+ file://hugs.png"
+LICENSE = "BSD"
+PR = "r2"
+
+S = "${WORKDIR}/${PV}/src/unix"
+
+inherit autotools
+
+# disable STRIP as the generated Makefile falsely call arm-linux-strip
+# on compiling which leads to abortion of the compile
+# we strip manually anyway so disabling it here is 'ok'
+EXTRA_OECONF = "--disable-ffi STRIP=true"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd ../ && oe_runmake
+}
+
+do_install() {
+ cd ../ && autotools_do_install
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/hugs.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/hugs.png ${D}${datadir}/pixmaps/
+}