aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icecast
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/icecast')
-rw-r--r--recipes/icecast/icecast_2.3.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/icecast/icecast_2.3.2.bb b/recipes/icecast/icecast_2.3.2.bb
new file mode 100644
index 0000000000..bb82d59557
--- /dev/null
+++ b/recipes/icecast/icecast_2.3.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Icecast streaming media server"
+LICENSE = "GPLv2"
+
+DEPENDS = "libvorbis libogg libtheora speex libxslt libxslt-native"
+
+PR = "r2"
+
+SRC_URI = "http://downloads.us.xiph.org/releases/icecast/${PN}-${PV}.tar.gz"
+
+# disable curl
+EXTRA_OECONF = " \
+ --without-curl \
+ --with-ogg=${STAGING_LIBDIR} \
+ --with-vorbis=${STAGING_LIBDIR} \
+ --with-theora=${STAGING_LIBDIR} \
+ --with-speex=${STAGING_LIBDIR} \
+ "
+
+S = "${WORKDIR}/${PN}-${PV}"
+inherit autotools
+