aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icewm/icewm_1.2.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/icewm/icewm_1.2.30.bb')
-rw-r--r--recipes/icewm/icewm_1.2.30.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/icewm/icewm_1.2.30.bb b/recipes/icewm/icewm_1.2.30.bb
new file mode 100644
index 0000000000..cd8cfe5bde
--- /dev/null
+++ b/recipes/icewm/icewm_1.2.30.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "IceWM Window Manager"
+SECTION = "x11/wm"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft mkfontdir-native"
+RRECOMMENDS = "ttf-dejavu-sans"
+PR = "r2"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/icewm/icewm-${PV}.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://configure.patch;patch=1 \
+"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} \
+ --with-mkfontdir=${STAGING_BINDIR_NATIVE}/mkfontdir"
+
+pkg_postinst() {
+update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/icewm-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager /usr/bin/icewm-session
+}