summaryrefslogtreecommitdiffstats
path: root/recipes/images/fso-illume-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/fso-illume-image.bb')
-rw-r--r--recipes/images/fso-illume-image.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes/images/fso-illume-image.bb b/recipes/images/fso-illume-image.bb
new file mode 100644
index 0000000000..189c8cba69
--- /dev/null
+++ b/recipes/images/fso-illume-image.bb
@@ -0,0 +1,83 @@
+#------------------------------------------------------
+# FSO-compliant Illume Image Recipe
+#------------------------------------------------------
+
+require fso-image.inc
+
+PV = "1.1"
+PR = "r1"
+
+# no languages for now
+IMAGE_LINGUAS = ""
+
+BASE_INSTALL = "\
+ task-base \
+"
+
+ILLUME_THEME = "illume-theme-fso"
+
+X_INSTALL = "\
+ task-x11-illume \
+ task-fonts-truetype-core \
+"
+
+X_INSTALL_append_om-gta02 = "\
+ task-fonts-truetype-chinese \
+ task-fonts-truetype-japanese \
+"
+
+# tools
+TOOLS_INSTALL = "\
+ task-cli-tools \
+ task-cli-tools-python \
+"
+
+# audio
+AUDIO_INSTALL = "\
+ alsa-oss \
+ alsa-state \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ gst-meta-audio \
+ gst-plugin-modplug \
+ gst-plugin-sid \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)} \
+ fso-sounds \
+"
+
+GTK_INSTALL = "\
+ tango-icon-theme \
+ vala-terminal \
+ gpe-scap \
+"
+
+# FIXME these should rather be part of alsa-state,
+# once Om stabilizes them...
+AUDIO_INSTALL_append_om-gta01 = "\
+ openmoko-alsa-scenarios \
+"
+AUDIO_INSTALL_append_om-gta02 = "\
+ openmoko-alsa-scenarios \
+"
+
+# python
+PYTHON_INSTALL = "\
+ python-codecs \
+ python-gst \
+"
+
+# fso
+FSO_INSTALL = "\
+ task-fso-compliance \
+"
+
+IMAGE_INSTALL = "\
+ ${BASE_INSTALL} \
+ ${X_INSTALL} \
+ ${GTK_INSTALL} \
+ ${GAMES_INSTALL} \
+ ${AUDIO_INSTALL} \
+ ${TOOLS_INSTALL} \
+ ${PYTHON_INSTALL} \
+ ${FSO_INSTALL} \
+"