summaryrefslogtreecommitdiffstats
path: root/recipes/images/gnuradio-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/gnuradio-image.bb')
-rw-r--r--recipes/images/gnuradio-image.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/images/gnuradio-image.bb b/recipes/images/gnuradio-image.bb
new file mode 100644
index 0000000000..5421584481
--- /dev/null
+++ b/recipes/images/gnuradio-image.bb
@@ -0,0 +1,26 @@
+#GNU radio image
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+IMAGE_EXTRA_INSTALL ?= ""
+
+DEPENDS = "task-base-extended \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+IMAGE_INSTALL = "task-base-extended \
+ ${IMAGE_EXTRA_INSTALL} \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ oprofile \
+ screen \
+ ntp ntp-bin \
+ make \
+ nfs-utils-client \
+ gnuradio gnuradio-examples \
+ "
+
+export IMAGE_BASENAME = "gnuradio-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+