aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/imote2-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/imote2-image.bb')
-rw-r--r--recipes/images/imote2-image.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/images/imote2-image.bb b/recipes/images/imote2-image.bb
new file mode 100644
index 0000000000..92578e9bdf
--- /dev/null
+++ b/recipes/images/imote2-image.bb
@@ -0,0 +1,18 @@
+# iMote2 mage based on Angstrom minimalist image
+
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+IMAGE_INSTALL = "task-boot \
+ util-linux-ng-mount util-linux-ng-umount \
+ ${DISTRO_SSH_DAEMON} \
+ lowpan-tools \
+ ibrdtn \
+ angstrom-version \
+ "
+
+export IMAGE_BASENAME = "imote2-image"
+IMAGE_LINGUAS = ""
+
+inherit image